Archive Generated December 23rd, 2018
Help! - .ZIP file inside a .NDS ROM
Author Posted on 2018/02/28
User 640 Hi, can somebody help me please?

The thing is: I'm trying to modify files from Dirt 2 NDS ROM file, but all the game resources are stored inside a .ZIP file called "vfs". I've tried to replace files directly to the .ZIP and compress it to the .NDS, but when I try to play either from my DS or Desmume the game freezes at a white screen. Desmume's output log shows lots of "WARNING! 8BIT DMA ACCESS" and two errors: "ERROR 8bit DIVCNT+2 READ" "ERROR 8bit SQRTCNT+2 READ". I asume tah the files contained in the original .ZIP file are compressed in a different way than the new ones I include, but I can't figure out how to fix it. Any ideas? (I'm using Winrar to modify the .ZIP)
Author Posted on 2018/03/01
PabloMK7 Open the file with a hex editor and send a screenshot of the first bytes
Author Posted on 2018/03/01
User 640 Using Tinke's Hex viewer:

Original vfs.zip file: http://s1243.photobucket.com/user/Alfadelta9/media/vfs%20original_zpskoxvtp6h.png.html?sort=3&o=0

Modified vfs.zip file: http://s1243.photobucket.com/user/Alfadelta9/media/vfs%20modified_zps320wiavz.png.html?sort=3&o=1
Author Posted on 2018/03/02
PabloMK7 Try using 7-Zip instead.
Author Posted on 2018/03/02
テクニカル諏訪子 Just tried to replace the word "Mexico" in-game by "China." (including the dot) to see what happens first hand.
The only difference is that Desmume force quits on load after the change.

I used Engrampa to replace files in the zip file, Engrampa is the default archive manager of Linux distributions running MATE.
So I think it's indeed a matter of compression, not the archive manager used.